Strona główna forum Wsparcie Problemy z działaniem Problem po instalacji z wyświetlaniem stron

Problem po instalacji z wyświetlaniem stron

Wszystkie problemy związane z działaniem sklepu...

FoX

Posty: 4
Gadu-Gadu: 0

Witam wszystkich,

Na wstępie zaznaczę iż jestem początkującym użytkownikiem, także proszę o wyrozumiałość. Mam problem z poprawnym wyświetlaniem strony głównej. Postanowiłem przetestować Magento na domowym serwerze. Instalacja przebiegła bez błędów i problemów, lecz tuż po zakończeniu i wyświetleniu frontendu ładuje się coś takiego:

http://img706.imageshack.us/img706/3691 ... agento.jpg

Po dodaniu nowych kategorii są one widoczne jedynie w panelu admina. Z produktami jest to samo, pojawiają się dopiero przy przeglądaniu mapy strony. Być może wina leży po stronie konfiguracji php, albo bazy danych? Jak wspomniałem, dopiero raczkuję w tym temacie. Nie wgrałem sample data, ale to chyba nie jest wymagane? Bardzo proszę o pomoc.

Magento v. 1.4.0.1
Serwer Apache2 na debianie { PHP 5.2.6 + lenny8, MySQL 5, itd.}

Problem po instalacji z wyświetlaniem stron

PostTeraz jest 22 paź 2020, o 19:26
Google

Posty: 427
Lokalizacja: Internet


Posty: 310
Gadu-Gadu: 3279331

odswiezyles cache??

FoX

Posty: 4
Gadu-Gadu: 0

Tak, nie pomaga :(


Posty: 73
Gadu-Gadu: 277722

A czy nowe kategorie dodałeś w domyślnie utworzonej kategorii ROOT?
SingleMalt.pl | The real taste of whisky

FoX

Posty: 4
Gadu-Gadu: 0

Podkategorie wyświetlają się po dodaniu do utworzonej domyślnie kategorii, ale przydzielone do nich produkty nadal są niewidoczne(tak, 'is active' = 'yes'). Inne kategorie root się nie wyświetlają. Wszystko wygląda w porządku z poziomu administracji, ale na frontendzie same kłopoty :/


Posty: 73
Gadu-Gadu: 277722

Ok, jest postęp. Tzn kategorie podpięte do root są widoczne, ale produkty nie. Rozumiem ze tworzy Ci sie juz automatycznie menu na glownej z kategoriami.
Aby produkt byl widoczny musisz:
1) przypiąc go do widocznej kategorii (ale to pewnie juz zrobiles) - zakladka "Kategorie"
2) przypiac go do witryny - zakładka "Witryny"
3) ustawic widocznosc produktu na "Katalog" lub "Katalog, wyszukiwanie" - zakladka "Ogolne"
4) i wreszcie produkt trzeba wlaczyc w polu "Status" - ta sama zakladka "Ogolne"
Wiem ze moze sie to wydawac nie takie proste i nie do konca potrzebne, ale te wszystkie mechanizmy daja na prawde ogromna elastycznosc w tworzeniu katalogu produktow, a raczej wielu katalogow produktow, szczegolnie gdy myslisz o prowadzeniu wielu sklepow :)
Daj znac czy sie udalo,
pozdrawiam
Wiktor
SingleMalt.pl | The real taste of whisky

FoX

Posty: 4
Gadu-Gadu: 0

Działa! Dzięki serdeczne :D Powoli łapię o co w tym wszystkim chodzi. Musiałem coś wcześniej poknocić przy ustawieniach. Faktycznie, ogrom parametrów, ale widzę w tym również ogromny potencjał.

Niemniej jednak przy zapisywaniu produktu do drugiego sklepu pojawił się błąd 'URL rewrite save problem'. Czy chodzi tutaj o wyłączony 'mod_rewrite' w apaczu?


Posty: 73
Gadu-Gadu: 277722

Ciesze się, że poszło :)
Co zapisu w dwoch sklepach, rozumiem ze robisz to przypinajac produkt do dwoch witryn. Kazda z nich powinna miec ustawiony inny adres www. Wowczas linki beda unikalne i nie powinno byc problemu, ale dopiero zbieram sie zeby to potestowac, wiec moze ktos inny Ci pomoze,
pozdrawiam
Wiktor
SingleMalt.pl | The real taste of whisky


Posty: 9
Gadu-Gadu: 0

Witam serdecznie,

Posiadam ten sam problem, zrobiłem wszystko wg instrukcji, jednak dalej nie widać żadnych zmian.. Na głównej wciąż brak jakichkolwiek produktów, kategorię po lewo też się nie wyświetlają. Jakieś pomysły?
Obrazek

edit: podgrzewam temat..


Powrót do Problemy z działaniem



cron