Strona główna forum Wsparcie Instalacja Problem z instalacją

Problem z instalacją

Pytania i rozwiązania problemów dotyczących instalacji Magento oraz modułów współpracujących...

Post 21 maja 2011, o 10:27

Posty: 11
Gadu-Gadu: 0

Witam
Od wczoraj próbuje zainstalować magento na serwerze home.pl ale po tworzeniu konta admina wyskakuje mi błąd 403 Forbidden You don't have permission to access this document. O pomoc poprosiłem zespół home.pl kazali usunąć plik .htaccess z katalogu errors ale nic to nie dało dalej wyświetlał się błąd raport z błędu czy ktoś wie w czym może być problem?

a:5:{i:0;s:49:"Validate class not found from basename 'NotEmpty'";i:1;s:934:"#0 /app/code/core/Mage/Admin/Model/User.php(380): Zend_Validate::is('admin', 'NotEmpty')
#1 /app/code/core/Mage/Install/Model/Installer.php(227): Mage_Admin_Model_User->validate()
#2 /app/code/core/Mage/Install/controllers/WizardController.php(395): Mage_Install_Model_Installer->validateAndPrepareAdministrator(Array)
#3 /app/code/core/Mage/Core/Controller/Varien/Action.php(420): Mage_Install_WizardController->administratorPostAction()
#4 /app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(253): Mage_Core_Controller_Varien_Action->dispatch('administratorPo...')
#5 /app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#6 /app/code/core/Mage/Core/Model/App.php(340): Mage_Core_Controller_Varien_Front->dispatch()
#7 /app/Mage.php(627): Mage_Core_Model_App->run(Array)
#8 /index.php(80): Mage::run('', 'store')
#9 {main}";s:3:"url";s:44:"/index.php/install/wizard/administratorPost/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

Problem z instalacją

PostTeraz jest 21 lut 2018, o 13:01
Google

Posty: 427
Lokalizacja: Internet

Post 22 maja 2011, o 22:33

Posty: 26
Lokalizacja: Kraków
Gadu-Gadu: 22740034

magento na serwerze home.pl

Hmmmm, ciekawe. Po co to tam robisz? Przecież i tak nic z tego nie wyjdzie. Chyba, że chcesz mieć sklep bez produktów, wtedy może home.pl wystarczy. W innym przypadku zapomnij o tej firmie. Sprawdź ofertę Konrada, albo jakiś dedyk.
Wdrożenia magento i poprawki, instalacja modułów www.sklepymagento.eu

Post 23 maja 2011, o 13:44

Posty: 428
Lokalizacja: W-wka
Gadu-Gadu: 36599

Zapomnij albo o home.pl albo o Magento
http://transit.waw.pl - Sklep oparty o Magento

Post 18 sty 2012, o 10:31

Posty: 1
Gadu-Gadu: 0

Temat dość stary, ale może komuś się przyda na przyszłość:

Aby Magento od wersji 1.5 w górę działało poprawnie na serwerze home.pl należy skierować domenę sklepu na główny katalog konta, a sam sklep umieścić w podkatalogu. Następnie w pliku .htaccess, który powinien być zamieszczony w roocie konta należy wpisać następujące reguły:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^(www\.)?subdomena\.domena\.pl$ [NC]
RewriteCond %{REQUEST_FILENAME} !/podkatalog/
RewriteRule ^(.*)$ /podkatalog/$1 [L]


Kolejną rzeczą, z którą trzeba się zmierzyć w przypadku instalowania Magento na home.pl jest usunięcie index.php z adresów zarówno frontendu jak i backendu. Aby usunąć index.php z adresów frontendu należy zalogować się do panelu administracyjnego, następnie Konfiguracji -> Sieć (ang. Web) i w zakładce "Optymalizacja pod wyszukiwarki" (ang. "Search Engine Optimization") ustawić pole "Używaj przekierowań serwera" (ang. "Use Web Server Rewrites") na "Tak".

Najprostszym sposobem na pozbycie się index.php z sekcji backendowej jest zainstalowanie modułu http://www.magentocommerce.com/magento- ... rites.html i w nowopowstałej sekcji Konfiguracja -> Administrator ustawienie w zakładce "Podstawowy URL dla sekcji Admin" (ang. "Admin Base URL") pola "Allow URL rewrites" na "Tak".

Wyczyszczenie cache i ponownie załadowanie strony powinno umożliwić normalne poruszanie się po stronie i poprawne działanie wszystkich mechanizmów.

Post 9 mar 2017, o 19:51

Posty: 1
Gadu-Gadu: 0

to ja może także dodam coś do starego wątku, może się komuś przyda:
instalacja wersji 1.9.3 na home.pl
stara wersja sklepu działała według powyższego wzoru, nowa (jako testowa) zainstalowana "obok" w katalogu głównym serwera:
/stara
/nowa
dostęp przez http://www.mydomain.pl/nowa
wszystko działało do momentu próby włączenia testowej pod domenę główną.
Objawy:
wszystko działa, ale nie można zrealizować koszyka, error:
"Validate class not found from basename 'NotEmpty'";i:1;s:926:"#0 /app/code/core/Mage/Customer/Model/Customer.php(859):
SOLVED:
W panelu konfiguracji domeny zmieniamy z:
brak przekierowania
na:
Włącz przekierowanie na podkatalog bez separacji serwisu : /nowa

Znalazłem po "tylko" pół dnia grzebania...
pzdr

Post 4 sty 2018, o 14:36

Posty: 1
Gadu-Gadu: 0

czesc


Powrót do Instalacja